summaryrefslogtreecommitdiff
path: root/git-core.spec.in
AgeCommit message (Collapse)Author
2005-11-17GIT 0.99.9j aka 1.0rc3v1.0rc3v0.99.9jJunio C Hamano
Signed-off-by: Junio C Hamano <junkio@cox.net>
2005-11-13Split gitk into seperate RPM packageThomas Matysik
I don't want to have to install x11-libs and all it's dependencies on my headless machines, so this patch splits gitk out of the RPM. The .deb already appears to have gitk split out. Signed-off-by: Thomas Matysik <thomas@matysik.co.nz> Signed-off-by: Junio C Hamano <junkio@cox.net>
2005-11-13Add expat and expat-devel dependencies (for http-push) to RPM spec.Thomas Matysik
Signed-off-by: Thomas Matysik <thomas@matysik.co.nz> Signed-off-by: Junio C Hamano <junkio@cox.net>
2005-11-11RPM: arch submodule needs tla.Junio C Hamano
Noticed by Horst von Brand. Signed-off-by: Junio C Hamano <junkio@cox.net>
2005-11-11specfile cleanupsChris Wright
Some specfile cleanups after the split. - zlib dependency fix, current method is inconsistent, you can potentially build a package that you can't install on machine you built it on - Add proper defattr - Remove trailing '.' in summary - Add docs to split up packages - Add git-core dependency for each subpackage - Move arch import to separate package as well Signed-off-by: Chris Wright <chrisw@osdl.org> Signed-off-by: Junio C Hamano <junkio@cox.net>
2005-11-10Add missing git-core and cvsps RPM dependencies.Jim Radford
Signed-off-by: Jim Radford <radford@blackbean.org> Signed-off-by: Junio C Hamano <junkio@cox.net>
2005-11-08Separate RPMS for programs with non-standard dependencies.Jim Radford
Signed-off-by: Jim Radford <radford@blackbean.org> Signed-off-by: Junio C Hamano <junkio@cox.net>
2005-10-24Require zlib >= 1.2 for RPM.Andreas Ericsson
git-update-index requires zlib >= 1.2, which introduced the *Bound functions. Signed-off-by: Junio C Hamano <junkio@cox.net>
2005-09-27COPTS -> CFLAGSH. Peter Anvin
2005-09-27Parallelize the buildH. Peter Anvin
2005-09-27Really require tk 8.4 (RPM)Junio C Hamano
**BLUSH** Signed-off-by: Junio C Hamano <junkio@cox.net>
2005-09-27Require tk 8.4 (RPM)Junio C Hamano
Signed-off-by: Junio C Hamano <junkio@cox.net>
2005-09-20Ship our own copy of subprocess.pyJunio C Hamano
so people without the latest Python could run merge-recursive. Signed-off-by: Junio C Hamano <junkio@cox.net>
2005-09-16[PATCH] Update git-core.spec.inChris Wright
Update git-core spec file based on feedback from Fedora Extras review. - update BuildRoot to be more specific - eliminate Requires that must be satisfied for base system install - drop Vendor - use dist tag to differentiate between branches - own %{_datadir}/git-core/ - use RPM_OPT_FLAGS in spec file Signed-off-by: Chris Wright <chrisw@osdl.org> Signed-off-by: Junio C Hamano <junkio@cox.net>
2005-09-16[PATCH] Require less in RPM specHorst von Brand
... and the next one will be the one to do Debian, naturally. Signed-off-by: Junio C Hamano <junkio@cox.net>
2005-09-13[PATCH] There are several undocumented dependenciesHorst von Brand
There are several undocumented dependencies in the .spec and in the INSTALL files. The following is from Fedora, perhaps other RPM distributions call the packages differently. Also, the manpages aren't always installed gzipped. Updates to git-core.spec.in file: - Some git scripts use Perl - gitk needs wish, which is part of TCL/Tk. - curl is used all over - Need the ssh program from openssh-clients Updates to INSTALL: - Mention wish - Mention ssh Signed-off-by: Horst H. von Brand <vonbrand@inf.utfsm.cl>
2005-09-11Add a new merge strategy by Fredrik Kuivinen.Junio C Hamano
I really wanted to try this out, instead of asking for an adjustment to the 'git merge' driver and waiting. For now the new strategy is called 'fredrik' and not in the list of default strategies to be tried. The script wants Python 2.4 so this commit also adjusts Debian and RPM build procecure files. Signed-off-by: Junio C Hamano <junkio@cox.net>
2005-08-12Adjust binary packaging to dest=>DESTDIR change.Junio C Hamano
Signed-off-by: Junio C Hamano <junkio@cox.net>
2005-08-12Make tools/ directory first-class citizen.Junio C Hamano
Tools directory being separate is just a historical coincidence. Build and install together with the main directory, just like the clean target does. Signed-off-by: Junio C Hamano <junkio@cox.net>
2005-08-08Change RPM dependency from Prereq to Requires.Junio C Hamano
Sergey Vlasov says we do not pre-require (i.e. required packages during installation) the dependencies, and should use Requires instead of Prereq. Knowing nothing about RPM, I just believe him. Signed-off-by: Junio C Hamano <junkio@cox.net>
2005-08-08[PATCH] RPM spec updates.Horst von Brand
Fix description and clean up the spec file. Signed-off-by: Junio C Hamano <junkio@cox.net>
2005-08-07Fix RPM build that omitted templates and tools.Junio C Hamano
Many many thanks go to Chris Wright and H. Peter Anvin whose help were essential to get me going this build. Signed-off-by: Junio C Hamano <junkio@cox.net>
2005-08-07GIT 0.99.4 (release candidate)Junio C Hamano
This is my first attempt to adjust Debian and RPM to pass prefix, to prepare the 0.99.4 release. It updates debian/rules and git-core.spec.in to properly pass prefix when building binary packages. It also updates debian/changelog to make the resulting binary package name 0.99.4; this is not needed on the RPM side (it takes the version number from the main Makefile). Signed-off-by: Junio C Hamano <junkio@cox.net>
2005-07-15[PATCH] Update the spec file so it can build and install the documentationEric W. Biederman
If you don't want the documentation simply build with make RPMBUILD="rpmbuild --without docs" Signed-off-by: Eric W. Biederman <ebiederm@xmission.com> Signed-off-by: Linus Torvalds <torvalds@osdl.org>
2005-07-12Rename the RPM from "git" to "git-core"Linus Torvalds
That way we avoid any confusion with "GNU Interactive Tools", and it's more descriptive anyway (the rpm documentation talks about how git is split into a "core" part and an "SCM" part, this makes it clear that this is the core one).