summaryrefslogtreecommitdiff
path: root/help.c
diff options
context:
space:
mode:
authorChristian Couder <chriscool@tuxfamily.org>2008-03-13 06:10:40 (GMT)
committerJunio C Hamano <gitster@pobox.com>2008-03-13 06:23:27 (GMT)
commit5fb0b3e007d6465af99d08121d46be82c649df5a (patch)
tree56281d300a052d59181ec34076e8ff94bd8bd6f4 /help.c
parentb8322ea83bc23499a2cef883d051859eb79fef25 (diff)
downloadgit-5fb0b3e007d6465af99d08121d46be82c649df5a.zip
git-5fb0b3e007d6465af99d08121d46be82c649df5a.tar.gz
git-5fb0b3e007d6465af99d08121d46be82c649df5a.tar.bz2
help: warn if specified 'man.viewer' is unsupported, instead of erroring out
When a document viewer that is unknown to the current version of git is specified in the .git/config file, instead of erroring out the process entirely, just issue a warning. It might be that the user usually is using a newer git that supports it (and the configuration is written for that version) but is temporarily using an older git that does not know the viewer. Signed-off-by: Christian Couder <chriscool@tuxfamily.org> Signed-off-by: Junio C Hamano <gitster@pobox.com>
Diffstat (limited to 'help.c')
-rw-r--r--help.c2
1 files changed, 1 insertions, 1 deletions
diff --git a/help.c b/help.c
index 5da8c9c..ecaca77 100644
--- a/help.c
+++ b/help.c
@@ -139,7 +139,7 @@ static int add_man_viewer(const char *value)
else if (!strcasecmp(value, "konqueror"))
do_add_man_viewer(exec_man_konqueror);
else
- return error("'%s': unsupported man viewer.", value);
+ warning("'%s': unsupported man viewer.", value);
return 0;
}