summaryrefslogtreecommitdiff
path: root/git_remote_helpers
diff options
context:
space:
mode:
authorJunio C Hamano <gitster@pobox.com>2013-01-09 16:25:47 (GMT)
committerJunio C Hamano <gitster@pobox.com>2013-01-09 16:25:48 (GMT)
commit48b7f524550ad46db95ec097e7f085160073a247 (patch)
treef46c13a0011afb2bd659011076721b1dc0cb154a /git_remote_helpers
parent00f1a867b4dde5065a579286a4de880142548bb2 (diff)
parenta33faf2827bfc7baea5d83ef1be8fe659a963355 (diff)
downloadgit-48b7f524550ad46db95ec097e7f085160073a247.zip
git-48b7f524550ad46db95ec097e7f085160073a247.tar.gz
git-48b7f524550ad46db95ec097e7f085160073a247.tar.bz2
Merge branch 'er/python-version-requirements'
Some python scripts we ship cannot be run with older versions of the interpreter. * er/python-version-requirements: Add checks to Python scripts for version dependencies.
Diffstat (limited to 'git_remote_helpers')
-rw-r--r--git_remote_helpers/git/__init__.py5
1 files changed, 5 insertions, 0 deletions
diff --git a/git_remote_helpers/git/__init__.py b/git_remote_helpers/git/__init__.py
index e69de29..1dbb1b0 100644
--- a/git_remote_helpers/git/__init__.py
+++ b/git_remote_helpers/git/__init__.py
@@ -0,0 +1,5 @@
+import sys
+if sys.hexversion < 0x02040000:
+ # The limiter is the subprocess module
+ sys.stderr.write("git_remote_helpers: requires Python 2.4 or later.\n")
+ sys.exit(1)