summaryrefslogtreecommitdiff
path: root/git-gui/lib
diff options
context:
space:
mode:
authorPratyush Yadav <me@yadavpratyush.com>2020-02-17 15:39:29 (GMT)
committerPratyush Yadav <me@yadavpratyush.com>2020-03-17 13:18:54 (GMT)
commit8a8efbe4140fd732e1890cbba6eaa85c0fac85e2 (patch)
tree35a1fdbfd785acc885d59072f195a766d6820718 /git-gui/lib
parent0d2116c6441079a5a1091e4cf152fd9d5fa9811b (diff)
downloadgit-8a8efbe4140fd732e1890cbba6eaa85c0fac85e2.zip
git-8a8efbe4140fd732e1890cbba6eaa85c0fac85e2.tar.gz
git-8a8efbe4140fd732e1890cbba6eaa85c0fac85e2.tar.bz2
git-gui: reduce Tcl version requirement from 8.6 to 8.5
On some MacOS distributions like High Sierra, Tcl 8.5 is shipped by default. This makes git-gui error out at startup because of the version mismatch. The only part that requires Tcl 8.6 is SimpleChord, which depends on TclOO. So, don't use it and use our homegrown class.tcl instead. This means some slight syntax changes. Since class.tcl doesn't have an "unknown" method like TclOO does, we can't just call '$note', but have to use '$note activate' instead. The constructor now needs a proper namespace qualifier. Update the documentation to reflect the new syntax. As of now, the only part of git-gui that needs Tcl 8.5 is a call to 'apply' in lib/index.tcl::lambda. Keep using it until someone shows up shouting that their OS ships with 8.4 only. Then we would have to look into implementing it in pure Tcl. Signed-off-by: Pratyush Yadav <me@yadavpratyush.com>
Diffstat (limited to 'git-gui/lib')
0 files changed, 0 insertions, 0 deletions