summaryrefslogtreecommitdiff
path: root/git-gui.sh
diff options
context:
space:
mode:
authorJulian Phillips <julian@quantumfyre.co.uk>2007-07-17 21:14:06 (GMT)
committerShawn O. Pearce <spearce@spearce.org>2007-07-18 01:48:57 (GMT)
commit91464dfb102d6143182d8f312b68486e9dceb103 (patch)
tree1909733645c3bd167b1b28a98ee66c0a95f357f1 /git-gui.sh
parent6eb420ef61317b2efa2993868a6302afed6ae60a (diff)
downloadgit-91464dfb102d6143182d8f312b68486e9dceb103.zip
git-91464dfb102d6143182d8f312b68486e9dceb103.tar.gz
git-91464dfb102d6143182d8f312b68486e9dceb103.tar.bz2
git-gui: Handle git versions of the form n.n.n.GIT
The git-gui version check doesn't handle versions of the form n.n.n.GIT which you can get by installing from an tarball produced by git-archive. Without this change you get an error of the form: 'Error in startup script: expected version number but got "1.5.3.GIT"' Signed-off-by: Julian Phillips <julian@quantumfyre.co.uk> Signed-off-by: Shawn O. Pearce <spearce@spearce.org>
Diffstat (limited to 'git-gui.sh')
-rwxr-xr-xgit-gui.sh1
1 files changed, 1 insertions, 0 deletions
diff --git a/git-gui.sh b/git-gui.sh
index d0b75c0..ebc2708 100755
--- a/git-gui.sh
+++ b/git-gui.sh
@@ -548,6 +548,7 @@ if {![regsub {^git version } $_git_version {} _git_version]} {
regsub -- {-dirty$} $_git_version {} _git_version
regsub {\.[0-9]+\.g[0-9a-f]+$} $_git_version {} _git_version
regsub {\.rc[0-9]+$} $_git_version {} _git_version
+regsub {\.GIT$} $_git_version {} _git_version
proc git-version {args} {
global _git_version