summaryrefslogtreecommitdiff
path: root/contrib/fast-import
diff options
context:
space:
mode:
authorDavid Aguilar <davvid@gmail.com>2013-02-24 00:50:19 (GMT)
committerJunio C Hamano <gitster@pobox.com>2013-02-24 21:31:08 (GMT)
commit61a7aaccf40a65840f5017901c8f4c19253c395a (patch)
tree856b39a6c271bbeb42f76f3640163a1c051c8d8d /contrib/fast-import
parentdd3a4ad95f5d10d8756fdf337004bb41b230b0fe (diff)
downloadgit-61a7aaccf40a65840f5017901c8f4c19253c395a.zip
git-61a7aaccf40a65840f5017901c8f4c19253c395a.tar.gz
git-61a7aaccf40a65840f5017901c8f4c19253c395a.tar.bz2
contrib/fast-import/import-zips.py: fix broken error message
The 'sys' module is not imported but all of the bits we want from it are. Adjust the script to not fail when run on old Python versions and fix the inconsistent use of tabs. Signed-off-by: David Aguilar <davvid@gmail.com> Signed-off-by: Junio C Hamano <gitster@pobox.com>
Diffstat (limited to 'contrib/fast-import')
-rwxr-xr-xcontrib/fast-import/import-zips.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/contrib/fast-import/import-zips.py b/contrib/fast-import/import-zips.py
index 8f2923d..1936a73 100755
--- a/contrib/fast-import/import-zips.py
+++ b/contrib/fast-import/import-zips.py
@@ -15,8 +15,8 @@ from zipfile import ZipFile
if hexversion < 0x01060000:
# The limiter is the zipfile module
- sys.stderr.write("import-zips.py: requires Python 1.6.0 or later.\n")
- sys.exit(1)
+ stderr.write("import-zips.py: requires Python 1.6.0 or later.\n")
+ exit(1)
if len(argv) < 2:
print 'usage:', argv[0], '<zipfile>...'