summaryrefslogtreecommitdiff
path: root/contrib/emacs
diff options
context:
space:
mode:
authorJakub Narebski <jnareb@gmail.com>2007-02-09 08:19:59 (GMT)
committerJunio C Hamano <junkio@cox.net>2007-02-09 08:52:52 (GMT)
commitf6f125fbaa79c097f10afdbd7103ec068df10397 (patch)
treeaf33e7d9d7424479148731f53ee0f97ea67ce82a /contrib/emacs
parentb52ba1a5d6c18250f497d3aba03943442766d9e1 (diff)
downloadgit-f6f125fbaa79c097f10afdbd7103ec068df10397.zip
git-f6f125fbaa79c097f10afdbd7103ec068df10397.tar.gz
git-f6f125fbaa79c097f10afdbd7103ec068df10397.tar.bz2
git-blame: Change installation instructions
Change installation instructions to using either "(require 'git-blame)" or appropriate autoload instruction in GNU Emacs init file, .emacs This required adding "(provide 'git-blame)" at the end of git-blame.el and adding [preliminary] docstring to `git-blame-mode' function for consistency (to mark function as interactive in `autoload' we have to provide docstring as DOCSTRING is third arg, and INTERACTIVE fourth, and both are optional). `git-blame-mode' is marked to autoload. While at it ensure that we add `git-blame-mode' to `minor-mode-alist' only once (in a way that does not depend on `cl' package). Signed-off-by: Jakub Narebski <jnareb@gmail.com> Signed-off-by: Junio C Hamano <junkio@cox.net>
Diffstat (limited to 'contrib/emacs')
-rw-r--r--contrib/emacs/git-blame.el23
1 files changed, 19 insertions, 4 deletions
diff --git a/contrib/emacs/git-blame.el b/contrib/emacs/git-blame.el
index ba9d8a6..56a548b 100644
--- a/contrib/emacs/git-blame.el
+++ b/contrib/emacs/git-blame.el
@@ -44,9 +44,20 @@
;;; Installation:
;;
-;; 1) Load into emacs: M-x load-file RET git-blame.el RET
-;; 2) Open a git-controlled file
-;; 3) Blame: M-x git-blame-mode
+;; To use this package, put it somewhere in `load-path' (or add
+;; directory with git-blame.el to `load-path'), and add the following
+;; line to your .emacs:
+;;
+;; (require 'git-blame)
+;;
+;; If you do not want to load this package before it is necessary, you
+;; can make use of the `autoload' feature, e.g. by adding to your .emacs
+;; the following lines
+;;
+;; (autoload 'git-blame-mode "git-blame"
+;; "Minor mode for incremental blame for Git." t)
+;;
+;; Then first use of `M-x git-blame-mode' would load the package.
;;; Compatibility:
;;
@@ -102,8 +113,12 @@
(defvar git-blame-mode nil)
(make-variable-buffer-local 'git-blame-mode)
-(push (list 'git-blame-mode " blame") minor-mode-alist)
+(unless (assq 'git-blame-mode minor-mode-alist)
+ (setq minor-mode-alist
+ (cons (list 'git-blame-mode " blame")
+ minor-mode-alist)))
+;;;###autoload
(defun git-blame-mode (&optional arg)
(interactive "P")
(if arg