summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKyle J. McKay <mackyle@gmail.com>2015-01-06 10:41:21 (GMT)
committerPat Thoyts <patthoyts@users.sourceforge.net>2015-01-13 00:42:03 (GMT)
commitce3e848b409a6ba30fe9e12354f309424ac247cd (patch)
treef44a9c9cf6ed155138edba9b8d582802bd1be141
parenta117fa211671b01449c81c7aed6766e55cb55c38 (diff)
downloadgit-ce3e848b409a6ba30fe9e12354f309424ac247cd.zip
git-ce3e848b409a6ba30fe9e12354f309424ac247cd.tar.gz
git-ce3e848b409a6ba30fe9e12354f309424ac247cd.tar.bz2
git-gui: reinstate support for Tcl 8.4
Tcl 8.5 introduced an extended vsatisfies syntax that is not supported by Tcl 8.4. Since only Tcl 8.4 is required this presents a problem. The extended syntax was used starting with Git 2.0.0 in commit b3f0c5c0 (git-gui: tolerate major version changes when comparing the git version, 2014-05-17), so that a major version change would still satisfy the condition. However, what we really want is just a basic version compare, so use vcompare instead to restore compatibility with Tcl 8.4. Signed-off-by: Kyle J. McKay <mackyle@gmail.com> Signed-off-by: Junio C Hamano <gitster@pobox.com> Signed-off-by: Pat Thoyts <patthoyts@users.sourceforge.net>
-rwxr-xr-xgit-gui.sh4
1 files changed, 2 insertions, 2 deletions
diff --git a/git-gui.sh b/git-gui.sh
index 0e4b05a..11048c7 100755
--- a/git-gui.sh
+++ b/git-gui.sh
@@ -1286,7 +1286,7 @@ load_config 0
apply_config
# v1.7.0 introduced --show-toplevel to return the canonical work-tree
-if {[package vsatisfies $_git_version 1.7.0-]} {
+if {[package vcompare $_git_version 1.7.0] >= 0} {
if { [is_Cygwin] } {
catch {set _gitworktree [exec cygpath --windows [git rev-parse --show-toplevel]]}
} else {
@@ -1542,7 +1542,7 @@ proc rescan_stage2 {fd after} {
close $fd
}
- if {[package vsatisfies $::_git_version 1.6.3-]} {
+ if {[package vcompare $::_git_version 1.6.3] >= 0} {
set ls_others [list --exclude-standard]
} else {
set ls_others [list --exclude-per-directory=.gitignore]